ܼ

VyOSδŪꡣ

Υ桼ȥѥɤϰʲ

ID : vyos
PW : vyos

⡼ɤؤڤؤϰʲޥѤ롣⡼ɤڤؤȡץץȤ#Ѳ롣

configure

ȿ

񤭹ͭˤϰʲޥѤ롣ξ֤Ǥ꤬ȿǤ줿ΤߤȤʤ뤿ᡢƵư򤹤ƤϾü롣

commit

¸

Ƥ¸롣¸줿ϺƵưƸ롣

save

Ƶư

롼κƵư/ߤԤˤϡconfigure⡼ɤȴɬפ롣

  • Ƶư
    $ reboot
    Proceed with reboot? (Yes/No) [No] yes
  • $ poweroff 
    Proceed with poweroff? (Yes/No) [No] yes

IPɥ쥹Ϳ

ƥ󥿡եIPɥ쥹ꤹ롣

  • configure
    set interfaces ethernet [Device] address [IP Address]/[Netmask(bit)]
    commit
    save
  • eth010.10.0.253Ϳ
    set interfaces ethernet eth0 address 10.10.0.253/16
  • eth1192.168.1.253Ϳ
    set interfaces ethernet eth1 address 192.168.1.253/24

ۥ̾

ƥΥۥ̾ꤹ롣

set system host-name [HostName]

DNSФ

DNSФԤnslookupޥѤǤ뤿ᡢcommit̾褬Ǥ뤳Ȥǧ롣

  • configure
    set system name-server [IP Address]
    commit
    save

ǥեȥȥ

ǥեȥȥΥɥ쥹ꤹ롣

  • configure
    set system gateway-address [IP Address]
    commit
    save

Ʊ

NTPФλȥॾλԤ

  • configure
    set system ntp server [IP Address]
    set system time-zone [TimeZone]
    commit
    save
  • nict.jpNTPФꤷॾꤹ
    configure
    set system ntp server ntp.nict.jp
    set system time-zone Asia/Tokyo
    commit
    save

ǥեȥॾUTCˤʤäƤ롣

# date
Wed Aug 16 06:12:33 UTC 2017

ॾcommitȡϻ֤ɽ롣

# set system time-zone Asia/Tokyo
[edit]
# commit
[ system time-zone Asia/Tokyo ]
Stopping enhanced syslogd: rsyslogd.
Starting enhanced syslogd: rsyslogd.

# date
Wed Aug 16 15:13:57 JST 2017

NAT

󥿡ե֤NATꤹ롣

  • configure
    set nat source rule [Rule Num] source address [Source Network]
    set nat source rule [Rule Num] translation address [NAT Address]
    set nat source rule [Rule Num] outbound-interface [Device]
    commit
    save
  • 10.10.0.253/16(eth0)Υ192.168.1.253(eth1)NAT
    configure
    set nat source rule 1 source address 10.10.0.253/16
    set nat source rule 1 translation address 192.168.1.253
    set nat source rule 1 outbound-interface eth1
    commit
    save

Firewall

FirewallδŪꡣ
eth0eth1ȴ̿ƵĤ뤬eth1eth0ȴƵݤꡣ

  • FirewallΥݥꥷ
    set firewall name OUTSIDE-IN default-action drop
    set firewall name OUTSIDE-IN rule 10 action accept
    set firewall name OUTSIDE-IN rule 10 state established enable
    set firewall name OUTSIDE-IN rule 10 state related enable]
    set firewall name OUTSIDE-IN rule 100 action drop
    set firewall name OUTSIDE-IN rule 100 state invalid enable
  • 󥿡ե˥ݥꥷŬѤ
    set interfaces ethernet eth1 firewall in name OUTSIDE-IN

ΥݡȤ̿ĤˤϡʲԤ
롼ֹ1199δ֤ǽʣʤֹŬѤ롣

  • HTTP(port 80)ε
    set firewall name OUTSIDE-IN rule 15 action accept
    set firewall name OUTSIDE-IN rule 15 protocol tcp
    set firewall name OUTSIDE-IN rule 15 destination port 80

ӥ

SSHͭ

⡼ȥѤSSHӥͭ硣

  • configure
    set service ssh
    commit
    save

SNMPͭ

ƻѤSNMPӥͭ硣

  • configure
    set service snmp community [COMMUNITY NAME]
    commit
    save

DHCPͭ

DHCPеǽͭ硣

  • configure
    set service dhcp-server shared-network-name [NAME] subnet [SUBNET/BIT] start [START IP] stop [END IP]
    set service dhcp-server shared-network-name [NAME] subnet [SUBNET/BIT] default-router [GATEWAY]
    set service dhcp-server shared-network-name [NAME] subnet [SUBNET/BIT] dns-server [DNS]
    commit
    save
  • ץ
    eth1172.16.0.254/16ˤˤ172.16.1.10250Υɥ쥹Ϳꡣ
    DNS(172.16.0.200)ꤹ롣
    configure
    set service dhcp-server shared-network-name eth1 subnet 172.16.0.0/16 start 172.16.1.10 stop 172.16.1.250
    set service dhcp-server shared-network-name eth1 subnet 172.16.0.0/16 default-router 172.16.0.254
    set service dhcp-server shared-network-name eth1 subnet 172.16.0.0/16 dns-server 172.16.0.200
    commit
    save

ȴ

Ⱥ

  • configure
    set system login user [UserName]
    set system login user [UserName] authentication plaintext-password [Password]
    commit
    save

ѥѹ

  • configure
    set system login user [UserName] authentication plaintext-password [Password]
    commit
    save

ȥå   Խ ʬ ʎގ̎ ź ʣ ̾ѹ   ǽ   إ   ǽRSS
Last-modified: 2017-09-04 () 12:18:24 (16d)